Úvod

csExcel úvod

 Top Next

Vítejte v programu csExcel

Vážený zákazníku, děkujeme Vám, že jste si vybral program csExcel. Doufáme, že budete s naším produktem spokojen a že se Vám s ním bude příjemně pracovat.

Tato dokumentace je psaná tak, aby uživatel byl postupně obeznámen s vlastnostmi a hlavně funkcemi programu jako celku, ale i jeho jednotlivých součástí. Předpokládá znalost základních pojmů a dovedností z prostředí operačních systémů Windows 95, 98, Millenium, 2000, XP nebo NT, bez nichž mohou být některé její pasáže nesrozumitelné. Pokud Vám tedy nic neříkají pojmy jako složka, soubor, okno nebo nevíte, jak aktivovat okno či stisknout tlačítko, doporučujeme Vám prostudovat si manuál nebo nápovědu operačního systému.

Uživatelské rozhraní pro tento produkt je velice jasné a užívání tohoto programu porozumíte za velmi krátkou dobu. Rozhraní je zpracováno tak, aby korespondovalo s velikostí vaší obrazovky a poskytovalo nejlepší ergonomické charakteristiky pro počítačové pracoviště.

Pro všechny funkce obsažené v produktu máte k dispozici nejen vstupy v hlavním menu, nýbrž i tlačítka se symboly, která vám umožní velice rychlé ovládání programu. Všechna tlačítka jsou vybavena stručným vysvětlujícím textem, což podstatně zkrátí Váš čas pro seznámení se s programem a pomůže vám vizuálně si připomenout jednotlivé funkce.

Copyright © 1996-2007 XSoft Software.
Všechna práva vyhrazena.


Popis

 Top Previous Next

· Umožňuje otevřít i uložit většinu souborů verzí Microsoft Excelu.
· Podporuje mnoho funkcí pro práci s listem.

Např. formátování buněk, vkládání funkcí do buněk, barva písma, barva buňky, formátování čísel, textu, datumu, propojení mezi listy a mnoho dalších.

· Podporuje mnoho matematických funkcí.
· Vlastní formát dat.
· Ukládá zašifrované soubory. Nepoužívá tak jako Ms Excel heslo do souboru, ale soubor je před uložením

kompletně zašifrovaný. Dešifrovat takový soubor je v současnosti pro uživatele nemožné. Tím je zaručeno

maximální bezpečí Vašich dat proti zneužití.

· Klíč šifrování má délku 1024bitů.
· Obsahuje tiskový manažér.
· a mnoho dalších.


Aktualizace produktu

Pro udržování našich informací v aktuálním stavu nebo zlepšení funkčnosti programu, provádíme pravidelnou aktualizaci produktu. Pokud máte zájem o aktualizační informace, požádejte nás o zaslání poslední verze produktu po jeho vydání.


Registrace programu

Registrace programu csExcel.

Informační program csExcel je třeba zaregistrovat. Registrace se provádí vložením unikátního licenčního klíče. Licenční klíč je kombinace určitého počtu číslic. Klíč získáte zakoupením příslušné licence programu csExcel.

Licenční klíč vložíte do programu některým z následujících postupů:

· Po spuštěním programu csExcel je možné zobrazit okno "Licencování produktu".

Zde můžete ukončit formulář tlačítkem "Licencovat později" nebo vyplnit údaje označené hvězdičkou

(podnikatelský subjekt vyplní také IČO a DIČ). Pokračujte stisknutím tlačítka "Další".

· Na další straně číslo 2. máte možnost vybrat požadovanou verzi programu a tlačítkem "Další" pokračovat

v licencování produktu nebo ukončit formulář.

· Na straně 3 se řiďte pokyny uvedenými na tomto formuláři (můžou se lišit podle verze programu).

Vygenerované licenční informace je možno zaslat prostřednictvím e-mailu, uvedeným na formuláři (stačí kliknout na uvedenou mailovou adresu a licenční zpráva bude automaticky vytvořena) nebo je možno licenční údaje vytisknout a zaslat poštou.

Po obdržení licenčního kódu tento vložte do textového pole označeného licence a stiskněte tlačítko "Dokončit". V případě správného licenčního čísla bude program zaregistrován podle Vámi uvedených údajů a připraven k požívání.

Pokud program csExcel klíč odmítá, zřejmě jste jej nesprávně přepsali nebo neodpovídá licence (např. licenční klíč pro jinou vezi produktu). V takovém případě kontaktujte prodejce programu csExcel nebo technickou podporu XSoftSoftware.


Technická podpora

Technická podpora

Pokud se vyskytnou nějaké problémy s instalací, registrací, používáním či nastavováním programu csExcel, můžete se obrátit na naší technickou podporu, kde Vám rádi a efektivně pomůžeme problém vyřešit.

E-mail : csExcel@corres.wz.cz

www : www.corres.wz.cz

V dotazu zaslaném elektronickou poštou uvádějte následující údaje:

· Verze programu csExcel (např. 1.1.15). Tuto informaci lze zjistit z okna "O Nás“.
· Verze operačního systému, na kterém dochází k potížím (např. Windows XP).
· Základní hardwarová konfigurace počítače (procesor, RAM).
· Způsob, jakým se připojujete k internetu (pouze v případě, že se problémy týkají online aktualizací nebo práce s elektronickou poštou). Důležité údaje jsou typ připojení (vytáčená linka, kabelový modem, LAN) a používané prostředky (proxy server, firewall...).
· Název a verze e-mailového klienta (pouze v případě, že se problémy týkají práce s elektronickou poštou).
· Text nebo screenshot chybových hlášení.
· Co nejpodrobnější popis, jak chybu opět vyvolat.

Obrázky použité v této nápovědě jsou pouze orientační a mohou se podle verze měnit.


Funkce

Arithmetic Operators

Arithmetic operators allow you to perform basic arithmetic operations.

Mnemonics | Operand Type | Example | Explanation
+ | Two arguments | = 5 + B1 | Adds the first argument’s value to the value of the second argument.
- | Two arguments | = A5 - B1 | Subtracts the second argument’s value from the value of the first one.
* | Two arguments | = A2 * A3 | Multiplies the first argument’s value by the value of the second argument.
/ | Two arguments | = A1 / PI() | Divides the first argument’s value by the value of the second argument.
^ | Two arguments | = B1 ^ A2 | Raises the first argument’s value to the power determined by the second argument’s value.

Logical operators

Logical operators perform comparison operations and return a logical value (TRUE or FALSE) as a result.

Mnemonics | Operand Type | Example | Explanation
= | Two arguments of logical types | = A1=A2 | The equality operation. Returns TRUE if the first argument is equal to the second one. Otherwise, returns FALSE.
<> | Two arguments of logical types | = A1<>B2 | The inequality operation. Returns TRUE if values within the list are not equal. Otherwise, returns FALSE.
< | Two arguments of logical types | = A1<B1 | The "Less than" operation. Returns TRUE if the first argument is less than the second one. Otherwise, returns FALSE.
> | Two arguments of logical types | = A1>100 | The "Greater than" operation. Returns TRUE if the first argument is greater than the second one. Otherwise, returns FALSE.
<= | Two arguments of logical types | = A2<=C4 | The "Less than or equal to" operation. Returns TRUE if the first argument is less than or equal to the second one. Otherwise, returns FALSE.
>= | Two arguments of logical types | = A2>=1.57 | The "Greater than or equal to" operation. Returns TRUE if the first argument is greater than or equal to the second one. Otherwise, returns FALSE.

Arithmetic functions

A set of mathematic and trigonometric functions.

Mnemonics | Operand Type | Example | Explanation
ABS | One argument of double type | =ABS(B6) | Returns the absolute value.
ACOS | One argument of double type | =ACOS(B16) | Returns the arccosine.
ACOSH | One argument of double type | =ACOSH(A1) | Returns the inverse hyperbolic cosine.
ASIN | One argument of double type | =ASIN(B6) | Returns the arcsine.
ASINH | One argument of double type | =ASINH(C2) | Returns the inverse hyperbolic sine of the argument.
ATAN | One argument of double type | =ATAN(C5) | Returns the arctangent.
ATAN2 | Two arguments of double type | =ATAN2(A1, A2) | Returns the arctangent using x- and y- coordinates.
ATANH | One argument of double type | =ATANH(D4) | Returns the inverse hyperbolic tangent.
CEILING | Two argument of double type | =CEILING(2.5, 1) | Rounds the first argument up to the nearest multiple based on the significance specified by the second argument.
COS | One argument of double type | =COS(A1) | Returns the cosine.
COSH | One argument of double type | =COSH(D7) | Returns the hyperbolic cosine.
COUNTIF | Two arguments: the range of cells and the condition of type string. | =COUNTIF(A1:A7,">2") | Counts the number of nonblank cells within a range which meet a given condition.
DEGREES | One argument of double type that specifies angle in radians | =DEGREES(PI()/2) | Converts radians to degrees.
EVEN | One argument of double type | =EVEN(-1) | Rounds the argument up to the nearest even integer.
EXP | One argument of double type | =EXP(C1) | Returns the exponent value of the argument.
FACT | One nonnegative argument | =FACT(2) | Returns the factorial of the argument.
FLOOR | Two arguments of double type | =FLOOR(-2.5, -2) | Rounds the first argument down, towards zero, to the nearest multiple of the significance specified by the second argument.
INT | Argument of type double | =INT(E4) | Rounds the argument down to the nearest integer.
LN | One argument of double type | =LN(C1) | Returns the natural logarithm.
LOG | Two arguments: the number and the base | =LOG(100, 10) | Returns the logarithm of a number to the specified base.
LOG10 | One argument of double type | =LOG10(1000) | Returns the base-10 logarithm of the argument.
MOD | Two arguments: a number and divisor | =MOD(4,3) | Returns the remainder after the number is divided by the divisor.
ODD | One argument of double type | =ODD(3.5) | Rounds the argument up to the nearest odd integer.
PI | No arguments required | =PI() | Returns the value of Pi.
POWER | Two arguments of double type: the number and the power | =POWER(A1,4) | Raises the number to the base.
RADIANS | One argument of type double that specifies angle in degrees. | =RADIANS(180) | Converts degrees to radians.
RAND | No arguments required | =RAND() | Returns a random number between 0 and 1.
ROUND | Two arguments: the number of double type and the number of digits | =ROUND(20.57, 1) | Rounds the first argument to the specified number of digits.
ROUNDDOWN | Two arguments of double type | =ROUNDDOWN(2.75,0) | Rounds the argument toward zero. The first argument specifies a number to round up. The second argument defines the number of digits to which you want to round the first argument.
ROUNDUP | Two arguments of double type | =ROUNDUP(-3.42,1) | Rounds the argument toward infinity. The first argument specifies a number to round up. The second argument defines the number of digits to which you want to round the first argument.
SIGN | One argument of double type | =SIGN(A2) | Returns the sign.
SIN | One argument of double type | =SIN(A1) | Returns the sine.
SINH | One argument of double type | =SINH(1) | Returns the hyperbolic sine.
SQRT | One argument of double type | =SQRT(B5) | Returns the square root.
SUM | A list of arguments | =SUM(A1:C12) =SUM(A1, 3.14, 1.57) | Sums all the values in the list.
SUMSQ | A list of arguments | =SUMSQ(B1:D1) =SUM(1, 2, 3, 4) | Sums the square of values in the list
TAN | One argument of double type | =TAN(C3) | Returns the tangent.
TANH | One argument of double type | =TANH(0) | Returns the hyperbolic tangent.
TRUNC | One argument of double type | =TRUNC(PI()) | Returns the integer part. Compare this with the Int function, which returns a double

Statistical functions

Basic statistical functions.

Mnemonics | Operand Type | Example | Explanation
AVERAGE | A list of arguments | =AVERAGE(A1:A5) =AVERAGE(10.3, 9.1) | Calculates the average value of values within the list.
AVERAGEA | A list of arguments | =AVERAGEA(A1:A5) | Calculates the average value of the non-empty cells referenced. AVERAGEA(range) equals SUM(range)/COUNTA(range).
COUNT | A list of arguments | =COUNT(A1:A4) =COUNT(1, 5, 8) | Returns the number of cells in a given range.
COUNTA | A list of arguments | =COUNTA(A1:A4) | Counts the number of non-empty cells in a given range.
COUNTBLANK | A list of arguments | =COUNTBLANK(A1:E1) | Counts the number of empty cells.
MAX | A list of arguments | =MAX(A1:D1) =MAX(A1, 100, C2) | Returns the largest argument value.
MIN | A list of arguments | =MIN(A1:D1) =MIN(0, C2) | Returns the smallest argument value.
SUM | A list of arguments | =SUM(A1:C12) =SUM(A1, 3.14, 1.57) | Sums values within the list.
SUMSQ | A list of arguments | =SUMSQ(B1:D1) =SUMSQ(1, 2, 3, 4) | Sums squares of values within the list.

Logical functions

Logical functions take logical values as arguments and return a logical value as a result.

Mnemonics | Operand Type | Example | Explanation
AND | A list of logical arguments | =AND(1<B4, B4<100) | Logical AND operation. Returns TRUE if all values within the list are TRUE; returns FALSE if one or more values within the list evaluates to FALSE.
FALSE | No arguments required | =FALSE() | Returns the logical value FALSE.
IF | Three arguments: the logical expression, the value to return if the expression succeeds, the value to return the expression fails. | =IF(A10<=100, "Within budget", "Over budget") | Returns the second argument if the logical expression evaluates to TRUE and the third argument otherwise.
NOT | One argument of logical type | =NOT(1>D4) | Logical NOT operation. Reverses the value of its argument.
OR | A list of logical arguments | =OR(A1>=10, A1<=–10) | Logical OR operation. Returns TRUE if any argument is TRUE; returns FALSE if all values within the list evaluate to FALSE.
TRUE | No arguments required. | =TRUE() | Returns the logical value TRUE.

Date and Time functions

Mnemonics | Operand Type | Example | Explanation
DATE | Three operands defining the year, month and day. | =DATE(1900,1,1) | Calculates the serial number that represents a specified date.
DAY | One argument defining the serial number of the required date. | =DAY(TODAY()) | Returns the day portion of a given date.
HOUR | One argument defining the serial number of the required date/time value. | =HOUR(NOW()) | Returns the hour portion of a given date/time value.
MONTH | One argument defining the serial number of the required date. | =MONTH(TODAY()) | Returns the month portion of a given date.
MINUTE | One argument defining the serial number of the required date/time value. | =MINUTE(NOW()) | Returns the minutes portion of a given date/time value.
NOW | No arguments required. | =NOW() | Returns the current time in general format. You can apply further formatting to the result of the function.
SECOND | One argument defining the serial number of the required date/time value. | =SECOND(NOW()) | Returns the seconds portion of a given date/time value.
TIME | Three arguments defining hour, minute and second parts of a time value. | =TIME(16, 48, 10) | Returns a decimal number for a specified time.
TODAY | No arguments required. | =TODAY() | Returns the serial number of the current date.
WEEKDAY | Two arguments: the serial number of the required date, weekday base. | =WEEKDAY(TODAY()) =WEEKDAY(DATE( 2002, 12, 1),1) returns 1(Sunday) | Returns the day of the week corresponding to the specified date. The weekday base identifies the first day of the week and determines the return value type: 1 or omitted: the first day of the week is Sunday. The function returns 1 for Sunday, 2 for Monday, etc. 2: the first day of the week is Monday. The function returns 1 for Monday, 2 for Tuesday, etc. 3: the first day of the week is Monday. The function returns 0 for Monday, 1 for Tuesday, etc.
YEAR | One argument defining the serial number of the required date. | =YEAR(TODAY()) | Returns the year portion of a given date.

Text functions

Mnemonics | Operand Type | Example | Explanation
& (ampersand) | Two arguments of type string | = "Yellow "&"river" | Concatenates specified strings.
CONCATENATE | A list of strings | =CONCATENATE("Developer", " Express") | Joins several text strings in one text string. An alternative to "&".
DOLLAR | Two arguments defining the value and the number of digits to the right of the decimal point in the output string. | =DOLLAR(957.344, 2) | Converts the number to text using currency format $#,##0.00_);($#,##0.00), with the decimals rounded to the specified number of places.
FIXED | The first argument of type double is required. The second argument of type integer is optional (the default value is 2). The third argument of type Boolean is optional. | =FIXED(1234.567, 1) | Rounds the first argument to the number of decimals determined by the second argument and returns it as a string. The third parameter specifies whether to omit commas in the output string.
LEFT | The first argument of type string is required. The second argument of type integer is optional. | =LEFT(A1) =LEFT(A1, 3) | Returns the first character or characters in a text string. The second parameter defines the number of characters to extract. The default value is 1.
LEN | One argument of type string. | =LEN("ABC") | Returns the length of a given string.
LOWER | One argument of type string. | =LOWER(A1) | Converts a string to lowercase.
MID | The first argument is of type string, the second and the third arguments are of type integer. | =MID("ABC",3,1) | Returns the substring of a given text string. The position of the substring is defined by the second parameter. The third parameter specifies the number of characters to extract.
RIGHT | The first argument of type string is required. The second argument of type integer is optional. | =RIGHT(B2, 3) | Returns the last character or characters in a text string. The second parameter defines the number of characters to extract. The default value is 1.
TRIM | One argument of string type | =TRIM(" Express Spread Sheet ") | Removes all spaces from text except for single spaces between words.
UPPER | One argument of type string. | =UPPER(A1&A2) | Converts a string to uppercase.

IS functions

Functions which test the type of a value and return a Boolean result.

Mnemonics | Operand Type | Example | Explanation
ISBLANK | A value of any type | =ISBLANK(A1) | Returns TRUE if cell is empty.
ISERR | A value of any type | =ISERR(H1) | Returns TRUE if the cell contains any error value except #N/A.
ISERROR | A value of any type | =ISERROR(A7) | Returns TRUE if the cell contains any error value (#N/A, #VALUE!, #REF!, #DIV/0!, #NUM!, #NAME?, or #NULL!).
ISLOGICAL | A value of any type | =ISLOGICAL(C3) | Returns TRUE if the specified value refers to a logical value.
ISNA | A value of any type | =ISNA(E5) | Returns TRUE if the cell contains #N/A (value not available) error value.
ISNONTEXT | A value of any type | =ISNONTEXT(D4) | Returns TRUE if the cell does not contain text. Returns TRUE for blank cells.
ISNUMBER | A value of any type | =ISNUMBER(A2) | Returns TRUE if the cell contains a number.
ISTEXT | A value of any type | =ISTEXT(D1) | Returns TRUE if the specified cell contains text.


Ceník csExcel

Ceník

 Top Previous

Aktuální cenu programu csExcel naleznete na internetové adrese :

Ceník csExcel